Booked Scheduler Community Support
July 25, 2017, 04:33:36 AM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Booked 2.5 has been released!
 
   Home   Help Login Register  
Pages: [1]
  Print  
Author Topic: Error logging into booked  (Read 191 times)
samsiddhi
Newbie
*

Karma: 0
Posts: 4


« on: July 17, 2017, 06:19:16 AM »

Hi,

I am new to this forum. I am trying to set up booked_2.6.6 on my workstation running Ubuntu 14.04 LTS. Firstly it was not displaying the captcha for registration. I checked that "gd" was active but may be not gd2. I am using php version 5.5.9 . So I disabled the captcha from the config.php. After that I was able to register a new account in my booked database with email "myemail@gmail.com". However when I try to log in using this account, nothing happens. The password as validated (log pasted below). What could be wrong ? How do I go about debugging this? Will appreciate any help...

Thanks,
--
Samsiddhi

2017-07-17T10:22:06+05:30 [3166] DEBUG default - [User=  ()] Trying to log in as: myemail@gmail.com [File=/var/www/booking.com/public_html/booked/lib/Application/Authentication/Authentication.php,Line=95]
2017-07-17T10:22:06+05:30 [3166] DEBUG default - [User=  ()] User was found: myemail@gmail.com [File=/var/www/booking.com/public_html/booked/lib/Application/Authentication/Authentication.php,Line=103]
2017-07-17T10:22:06+05:30 [3166] DEBUG default - [User=  ()] User: myemail@gmail.com, was validated: 1 [File=/var/www/booking.com/public_html/booked/lib/Application/Authentication/Authentication.php,Line=115]
2017-07-17T10:22:06+05:30 [3166] DEBUG default - [User=  ()] Logging in with user: myemail@gmail.com [File=/var/www/booking.com/public_html/booked/lib/Application/Authentication/Authentication.php,Line=121]
Logged
davemason
Full Member
***

Karma: 0
Posts: 187


« Reply #1 on: July 17, 2017, 02:55:56 PM »

Hi, Welcome to the forum.

It wasn't clear from your post if you had formerly set up your $conf['settings']['admin.email'] to be "myemail@gmail.com" ? If not, then you're logging into a schedule with nothing in it and no way to administer it.

Hopefully it's that easy! If not, can you clarify (with a screenshot?) what you mean by "nothing happens" after you login. Hopefully it will be easier to diagnose.

Dave
Logged
samsiddhi
Newbie
*

Karma: 0
Posts: 4


« Reply #2 on: July 18, 2017, 07:20:28 AM »

Hi,

Thanks for ur reply. I had set myemail@gmailcom as admin email at some point, so it is there in config.php
However I don't know if something needed to be restarted after that change was made.

Here is the log again, and screenshot is attached..it is basically blank page, but the URL may be informative.

 Trying to log in as: myemail@gmail.com [File=/var/www/booking.com/public_html/booked/lib/Application/Authentication/Authentication.php,Line=95]
2017-07-18T12:40:44+05:30 [1326] DEBUG default - [User=  ()] User was found: myemail@gmail.com [File=/var/www/booking.com/public_html/booked/lib/Application/Authentication/Authentication.php,Line=103]
2017-07-18T12:40:44+05:30 [1326] DEBUG default - [User=  ()] User: myemail@gmail.com, was validated: 1 [File=/var/www/booking.com/public_html/booked/lib/Application/Authentication/Authentication.php,Line=115]
2017-07-18T12:40:44+05:30 [1326] DEBUG default - [User=  ()] Logging in with user: myemail@gmail.com [File=/var/www/booking.com/public_html/booked/lib/Application/Authentication/Authentication.php,Line=121]
Logged
davemason
Full Member
***

Karma: 0
Posts: 187


« Reply #3 on: July 18, 2017, 07:50:28 AM »

Can you please confirm your config script URL. You need to use the full public URL of your install. Errors here can cause you to be bumped back to login.

Should be something like:

https://example.com/booked/Web

Make sure you get the case right (IE Web vs web) as some have reported issues with this.

Dave

Logged
samsiddhi
Newbie
*

Karma: 0
Posts: 4


« Reply #4 on: July 18, 2017, 12:35:14 PM »

I think those things are fine. I am able to access the page from a different computer using
http://10.10.2.32/booked/Web/

and I could register myself with password, full name etc...

now when I try to log in, credentials are accepted but I get redirected to dashboard (as seen in the screen shot). If I give a wrong user name or password, I get the message "We could not match your username or password".

This is config path

/var/www/booking.com/public_html/booked/config/config.php

I had tried to install virtual host as in this link
https://www.digitalocean.com/community/tutorials/how-to-set-up-apache-virtual-hosts-on-ubuntu-14-04-lts

But somehow the http://booking.com/...   is not working. May be that could have broken something...
Logged
davemason
Full Member
***

Karma: 0
Posts: 187


« Reply #5 on: July 18, 2017, 02:29:09 PM »

Sorry for the confusion, what I meant was the config parameter called script.url:

Code:
$conf['settings']['script.url']
The full public URL to the root of this instance of Booked Scheduler. This should be the Web directory which contains files like bookings.php and calendar.php. If this value starts with //, then the protocol (http vs https) will be automatically detected.

So in your case, I guess it should be something like:

http://mywebsite.com/booked/Web

assuming your document root is at /var/www/booking.com/public_html
Logged
samsiddhi
Newbie
*

Karma: 0
Posts: 4


« Reply #6 on: July 19, 2017, 04:45:41 AM »

I think that has solved it....thanks a ton !  Smiley
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2006-2007, Simple Machines Valid XHTML 1.0! Valid CSS!