Booked Scheduler Community Support
October 22, 2017, 06:58:09 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Booked is proud to recommend Shift Capsule in the employee shift scheduling space www.ShiftCapsule.com
 
   Home   Help Login Register  
Pages: [1]
  Print  
Author Topic: single sign on (sso) with active directory authentication  (Read 1132 times)
thomast2
Newbie
*

Karma: 0
Posts: 3


« on: January 05, 2017, 01:08:27 PM »

Hi,

I see that since 2.6.3 there's a flag sso in the config file to enable Single sign on.

I added:
$conf['settings']['sso'] = 'true';
to the config file but it seems there's still no sso. we still have to enter login and password

we are using the AD authentication plugin.

this is a feature that i requested here:
https://sourceforge.net/p/phpscheduleit/feature-requests/312/
and has been closed.

thanks for your help! Smiley

regards,
Logged
nawras83
Newbie
*

Karma: 0
Posts: 2


« Reply #1 on: January 08, 2017, 09:19:24 AM »

You need to change the Authentication in configuration file like this:
$conf['settings']['plugins']['Authentication'] = 'CAS';
and set the CAS configuration  in file: CAS.config.php
Path : \plugins\Authentication\CAS\

hope this helps  Smiley
Logged
thomast2
Newbie
*

Karma: 0
Posts: 3


« Reply #2 on: January 09, 2017, 09:48:00 AM »

Hi,

Thank you but we're using AD authentication, not CAS.
We do not have a CAS server actually.
isn't there any other way?

I already detailed in the feature request a code sample on how to make it work:
https://sourceforge.net/p/phpscheduleit/feature-requests/312/

it works and that'd be great if you wouldn't have to tweak the code to our own needs on each new release.
that may help other people too.

regards,
Logged
m.maier
Newbie
*

Karma: 0
Posts: 4


« Reply #3 on: January 23, 2017, 08:45:02 AM »

Hi everyone,

same as thomast2 here. I've tried to get SSO to run.  But i don't have an reference point, why Authentication with AD works and SSO don't works.


My Config:

Ubuntu Server 14.04.5 LTS
Apache2 Version 2.4.7 (HTTP, HTTPS)
Booked Version 2.6.4 - Authentication = ActiveDirectory, (Version=3, use.SSL= false, use.SSO=true)

Thanks for help.

Logged
thomast2
Newbie
*

Karma: 0
Posts: 3


« Reply #4 on: April 20, 2017, 09:01:32 AM »

any hint on that subject? that would be great.
thanks!
Logged
pcichon
Newbie
*

Karma: 0
Posts: 7


« Reply #5 on: July 27, 2017, 11:16:39 AM »

Hey there,

I would be also interessted in this topic. Is there anyone who has some experience regarding SSO with AD?

Thanks,
Patrick
Logged
pcichon
Newbie
*

Karma: 0
Posts: 7


« Reply #6 on: September 11, 2017, 11:54:30 AM »

No one here with experience with this function? Just would be cool to know if it even is possible or not.

Thanks
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2006-2007, Simple Machines Valid XHTML 1.0! Valid CSS!