Booked Scheduler Community Support
October 30, 2014, 12:38:05 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Booked 2.5 has been released!
 
   Home   Help Login Register  
Pages: [1] 2
  Print  
Author Topic: Extremely basic installation issue  (Read 1698 times)
Scurmicurv
Newbie
*

Karma: 0
Posts: 28


« on: March 20, 2012, 08:49:31 AM »

OK, sorry to butt in with a question like this so soon after the other one, but... I'm actually getting stuck at the screen where I'm asked to supply MySQL User and Password. I type in the user I created in my web host's control panel for the database I'm using. What it returns to me is "Error selecting to mysql database.  Check entered username and password." But I know that it's correct info for the db user and it says clearly in the control panel that it has read and write permission. I can also see from the lines at the top of the screen where it asks for user details that it reads db name, db user and db host correctly from the config file.
So yea, I just wanted to see if anyone here can point out some very obvious mistake I must have done before I go ask my web host. 
Logged
wingoo
Full Member
***

Karma: 0
Posts: 108


« Reply #1 on: March 20, 2012, 09:00:54 AM »

I had the same issue, just use a manual install instead.

Create the database manualy, associate the user, then using phpadmin cpanel import the SQL files in the order listed to set up the structure and initialize. Note, at least one has a use phpscheduleit2 line at the top that needs to be removed before importing via cpanel or you will get an error.

There is no real need to import the last one with the test data.

Just change the config.php to true for enable login creation. Then create your first admin login by using the email address you set up in config as admin email. The new login will automatically be an admin if you use that email.

If you have problems with the captcha code, this can be disabled in config.php.

Once you have an admin login created, you can disable login creation in config again if you want to control creation of future logins yourself.

Hope this makes sense.
Logged
Scurmicurv
Newbie
*

Karma: 0
Posts: 28


« Reply #2 on: March 20, 2012, 09:12:27 AM »

M'kay, thanks, I'll go with that and see what happens. Just to be sure though:
As it stands, I've uploaded (obviously...) all the files to the server and tried running the installation - do I need to do anything else apart from adjusting the sql files locally (remove that top line) and do the procedure via cpanel? Like, I don't need to do a reupload of the whole thing, or upload the modified SQL files to the server via FTP or anything like that?
Logged
wingoo
Full Member
***

Karma: 0
Posts: 108


« Reply #3 on: March 20, 2012, 09:18:20 AM »

No youimport the sql files from your local copy, not the web server.

The only thing you may need to do is enable login creation in the config as this is disabled by default.
Logged
wingoo
Full Member
***

Karma: 0
Posts: 108


« Reply #4 on: March 20, 2012, 09:20:43 AM »

Forgot to mention, you dont import the create db sql file as you have created it manually.
Logged
wingoo
Full Member
***

Karma: 0
Posts: 108


« Reply #5 on: March 20, 2012, 09:22:57 AM »

I will be around for an hour or so if you have probs, then I will be gone as it is Night here.
Logged
Scurmicurv
Newbie
*

Karma: 0
Posts: 28


« Reply #6 on: March 20, 2012, 09:46:28 AM »

Thanks a lot for helping out!
Any which how, yea, now I've gotten as far as a login screen and try to create a new user with the e-mail I've entered as the admin one. I've set the line
$conf['settings']['allow.self.registration'] = 'true';

and even turned of the  captcha. However, when I try to create the user it simply gives me "Unknown error. Return to the last page you were on". Which isn't all that helpful, I'm afraid, but perhaps you know what the problem is anyway?
Logged
wingoo
Full Member
***

Karma: 0
Posts: 108


« Reply #7 on: March 20, 2012, 09:53:36 AM »

Check the database in phpadmin and see if the user was actually created.

If the user is there and you got this far it is likely that the problem now is an error in the config file.

Try creating the config again starting with the template one again.

When you are entering the info in the config, make sure you pay particular attention to the paths and any capitol letters in them.
Logged
wingoo
Full Member
***

Karma: 0
Posts: 108


« Reply #8 on: March 20, 2012, 09:59:38 AM »

Here is acopy of my config (with the users and the passwords starred out

<?php
/**
Copyright 2011-2012 Nick Korbel

This file is part of phpScheduleIt.

phpScheduleIt is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.

phpScheduleIt is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with phpScheduleIt.  If not, see <http://www.gnu.org/licenses/>.
*/

error_reporting(E_ALL & ~E_NOTICE & ~E_STRICT);
/**
 * Application configuration
 */
$conf['settings']['server.timezone'] = 'Australia/West';       // look up here http://php.net/manual/en/timezones.php
$conf['settings']['allow.self.registration'] = 'false';         // if users can register themselves
$conf['settings']['admin.email'] = '*******@***************;         // email address of admin user
$conf['settings']['default.page.size'] = '50';                  // number of records per page
$conf['settings']['enable.email'] = 'true';                     // global configuration to enable if any emails will be sent
$conf['settings']['default.language'] = 'en_gb';                // find your language in phpScheduleIt/lang directory
$conf['settings']['script.url'] = 'http://localhost/phpscheduleit/Web';      // public URL to the Web directory of this phpScheduleIt instance. this is the URL that appears when you are logging in
$conf['settings']['password.pattern'] = '/^[^\s]{6,}$/i';           // regular expression to enforce password complexity
$conf['settings']['schedule']['show.inaccessible.resources'] = 'true';  // whether or not resources that are inaccessible to the user are visible
$conf['settings']['reservation']['notify.created'] = 'true';    // notifying a booking event
$conf['settings']['image.upload.directory'] = 'Web/uploads/images'; // ie public_html/phpscheduleit/Web/uploads/images
$conf['settings']['image.upload.url'] = 'uploads/images';       // path to show uploaded images from, relative to script.url
$conf['settings']['cache.templates'] = 'true';                  // recommended, caching template files helps web pages render faster
$conf['settings']['registration.captcha.enabled'] = 'false';     // recommended, requires php_gd2.dll enabled in php.ini
$conf['settings']['inactivity.timeout'] = '30';              // minutes before the user is automatically logged out
/**
 * Database configuration
 */
$conf['settings']['database']['type'] = 'mysql';
$conf['settings']['database']['user'] = 'maddingt_********';        // database user with permission to the phpScheduleIt database
$conf['settings']['database']['password'] = '******';
$conf['settings']['database']['hostspec'] = 'localhost';        // ip, dns or named pipe
$conf['settings']['database']['name'] = 'maddingt_phpscheduleit2';
/**
 * Mail server configuration
 */
$conf['settings']['phpmailer']['mailer'] = 'mail';              // options are 'mail', 'smtp' or 'sendmail'
$conf['settings']['phpmailer']['smtp.host'] = '';               // 'smtp.university.ca'
$conf['settings']['phpmailer']['smtp.port'] = '25';
$conf['settings']['phpmailer']['smtp.secure'] = '';             // options are '', 'ssl' or 'tls'
$conf['settings']['phpmailer']['smtp.auth'] = 'true';           // options are 'true' or 'false'
$conf['settings']['phpmailer']['smtp.username'] = '';
$conf['settings']['phpmailer']['smtp.password'] = '';
$conf['settings']['phpmailer']['sendmail.path'] = '/usr/sbin/sendmail';
/**
 * Plugin configuration.  For more on plugins, see readme_installation.html
 */
$conf['settings']['plugins']['Authentication'] = '';
$conf['settings']['plugins']['Authorization'] = '';
$conf['settings']['plugins']['Permission'] = '';
$conf['settings']['plugins']['PreReservation'] = '';
$conf['settings']['plugins']['PostReservation'] = '';
/**
 * Installation settings
 */
$conf['settings']['install.password'] = '********';
?>
Logged
Scurmicurv
Newbie
*

Karma: 0
Posts: 28


« Reply #9 on: March 20, 2012, 10:10:04 AM »

Nah, the issue seems to be with creating the user in the installation, don't see how I missed out on this the first time around. The create-user.sql file has the following singe line:
GRANT ALL on phpscheduleit2.* to 'schedule_user'@'127.0.0.1' identified by 'password';

The cpanel gives a #1044, saying that my db user was denied access. My haphazard guess would be that I need to modify this line? I've already tried using
GRANT ALL on "my db name".* to 'schedule_user'@'127.0.0.1' identified by 'password';

which gave the same result. Sorry to be such a drag.
Logged
wingoo
Full Member
***

Karma: 0
Posts: 108


« Reply #10 on: March 20, 2012, 10:17:52 AM »

NP.

That one cant be run as an import and it is not needed if you created the db user in MySQL and granted all privelleges to them.

I would double check

The DB User you created has all rights and is associated with the DB

The DB name is correct in your config and matches the name of the DB created (including capitolisations)

The same user and password is in your config. Note Cpanel may prefix it and the database name with your user name (see maddingt_ in my config file, maddingt is my cpanel user)

the host spec (I used localhost)

the paths in your config to script etc are correct.
Logged
wingoo
Full Member
***

Karma: 0
Posts: 108


« Reply #11 on: March 21, 2012, 01:48:21 AM »

Did you get this resolved?
Logged
Scurmicurv
Newbie
*

Karma: 0
Posts: 28


« Reply #12 on: March 21, 2012, 06:33:37 AM »

I had to cut work short because of other work, but I'm getting back to it now for another go. Whichever way it turns out I'm very grateful for all the assistance!
Logged
wingoo
Full Member
***

Karma: 0
Posts: 108


« Reply #13 on: March 21, 2012, 07:57:27 AM »

You are very welcome Smiley
Logged
Scurmicurv
Newbie
*

Karma: 0
Posts: 28


« Reply #14 on: March 21, 2012, 08:48:48 AM »

Yep, as far as I can tell I did exactly the same thing today as I did yesterday, albeit by a far more direct route this time around. And what do you know, that worked and now I'm rolling. Ah, learning curve, how we love thee. Anyhows, thanks again!
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2007, Simple Machines Valid XHTML 1.0! Valid CSS!